【お知らせ】バージョン0.10.4でロボデザインがかわりました

JobAuto 0.10.4に伴うロボデザインの画面変更を、実際の操作画面の画像10枚とともに解説します。ツールバー・リボン・左サイドメニュー、共通部品、コントロールパネル、アクションフロー、ブラウザ操作・エクセル操作の変更点を確認できます。

バージョン0.10.4ではロボデザインが大きく変わりました。構成や使用方法に変更点がたくさん入りました。その変更点についてこのページではまとめています。

1.ロボデザインの見た目が変わりました。水色を基調にした色に変わりました。

2.ツールバー、リボン、左サイドメニューの内容が変わりました。

1)ツールバー

  • ファイル、アクションを削除
  • 従来のファイルで行っていた各設定は、設定内へ移動。
  • 共通部品(従来はカスタムアクション)を左サイドメニューから移動して追加。
  • データベースを左サイドメニューから移動して追加。
  • 左端にロボデザインで開いているプロジェクト名を表示

2)リボン

  • アクションを追加するためのアイコンを削除
  • ロボットを実行するための各ボタンを削除
  • RIDやプロジェクトの情報の表示を削除
  • ロボット名を表示、プルダウンでロボットを選択して開くように変更。
  • 使用する機会の多いロボットの新規作成などの機能を追加

3)左サイドメニュー

  • カスタムアクション(0.10.4から共通部品)、データベースを削除。ツールバーへ移動

3.共通部品(従来はカスタムアクションと呼んでいました)を開いたときの色が変更

ロボデザインで共通部品を開くとロボデザインの色が変わります。水色から、灰色がかった緑になります

4.コントールパネルの使い勝手の向上

1)従来はアクションとテスト(デバッグ)の2つのタブに分かれていました。アイコンを、1つにまとめました。

2)各アイコンに名前を付与しました。

3)ブランチや条件分岐を削除しました。ブランチや条件分岐の追加はアクションフロー内でアクションを右クリックして行います。

5.アクションフローでアクションを選択、右クリックしたときに表示されるメニューの整理を行いました。

1)アクションの追加が編集メニューを開いたときに表示されるようにしました。

2)アクションの削除をアクション操作の中に移動しました。

3)分岐操作内のブランチや条件分岐の追加は編集メニューからだけ行うようにしました(コントロールパネルから削除)。

6.ブラウザ操作のアクションの追加のしやすさの向上

1)操作したい個所を選択、右クリックしたときのアクションの表示を変更しました。選択した個所に応じて設定する候補のアクションが表示されます。候補にない場合は、全てのアクションをクリックして表示された一覧から選択します

2)操作個所の指定をボタンなどの名前か、タグ(xpath)で設定するかを選べます

7.エクセル操作のアクションの追加のしやすさの向上

1)操作個所を選択、右クリックして表示されるアクションの表示を変更しました。選択した操作個所に応じて設定する候補のアクションが表示されます。候補にない場合は、全てのアクションをクリックして表示された一覧から選択します

関連情報

リリースノート – 0.10.4 (2021-01-25)

JobAuto 0.10.4(2021年1月25日)のリリースノートです。ロボデザインのUI刷新、プロジェクト間でのロボット・共通部品のコピー、アプリ操作の文字マッチング、ブラウザ操作、ROBOWEBなどの機能追加・修正・不具合修正を掲載しています。

このページはリリース当時の変更内容を記録しています。各機能の操作方法は項目内の関連マニュアルをご確認ください。

機能追加

ロボデザイン

ROBOWEB

  • システム管理者画面に、スケジュール実行予定表を追加 ※マニュアルページはこちら
  • ログ一覧のステータスを「対処済み」に変更できるように修正。「エラーあり」「緊急停止」「時間打ち切り」「異常終了」の場合です。 ※マニュアルページ

アプリ操作

ブラウザ操作

  • 要素に対するアクション選択時、まずは該当しそうな候補を最初に出すように修正
  • マウスオーバー時に要素にフォーカスされるよう機能を追加
  • 選択された要素をクリックした際、処理対象が親要素へ移動するように修正
  • 要素に対するアクション(クリック、値入力、値取得等)に要素インデックスを追加
  • クリックして別windowが開いた際、続けてwindow切替画面を表示する機能を追加

変数操作

エクセル操作

その他

  • ログ出力アクションに「ログにスクリーンショットを含める」オプションを追加。ROBO_WEBのログ詳細画面からログ出力時の画面ショットを見れるようになる。

機能修正

ロボデザイン

  • ロボットダウンロード画面の表示を変更。プロジェクト一覧、レシピ一覧を名前順にソートして表示するように修正
  • デバッグ用として、ブラウザへのフォーカスの中断と再開ボタンを追加
  • 変数に対して、利用用途等のコメントを書ける欄を追加

ROBOWEB

  • スケジュール新規や編集でPC名やロボット名の選択設定をソートして表示するように修正
  • スケジュールの終了時刻を現在時刻から実際のロボットの終了時刻にするように修正
  • ログ一覧画面、Searchボックスに、–ではじまる入力をすると除外検索をできるように修正
  • スケジュール内で設定できる休日パターンについて、複数のパターンを設定できるように修正

アプリ操作

  • アプリ接続で接続先の一覧にアプリのタイトル以外にプロセスの一覧も表示するように修正
  • キー送信に、スペース、バックスペースを追加

エクセル操作

  • 各アクションで処理対象のファイルをブックインデックスだけでなく、ファイル名でも指定できるように修正

フォルダ操作

  • フォルダの繰り返し処理、特定の文字がフォルダ名に含んでいた場合、そのフォルダは繰り返し処理の対象外とするオプションを追加
  • フォルダコピーアクション、コピー先のフォルダへ強制的に上書きするオプションを追加

その他

  • メール送信アクション、ポート番号465でも送信できるように修正

バグフィックス

ROBOWEB

  • ROBO_WEBのスケジュールにて、打ち切り時間を設定した場合、実行することなく時間打ち切りになってしまう不具合の修正

ブラウザ操作

  • REST API のheaders、paramtersの変数が変数一覧にあがってこない不具合の修正、もし変数が存在しない際、赤文字ラベルにならない不具合の修正
  • フレーム切替アクションにてすべてのフレームを拾い切れていなかった不具合の修正

変数操作

  • 変数の値の加工の四則演算での桁あふれの不具合修正

関連情報

JobAutoのライセンス認証方法|ライセンスキーの適用手順

★ページの説明・概要

JobAutoへライセンスキーを適用し、 ライセンス認証を行う方法について説明します。

本契約後は、 JobAutoを使用するPCでRID(ロボID)を確認し、 製品サポートへお送りいただきます。

製品サポートから発行されたライセンスキーを、 ロボデザインのライセンス認証画面へ貼り付けて認証します。

ライセンス認証は、 RIDを確認したWindowsユーザーと同じユーザーで行ってください。

ライセンス認証する前に確認すること

ライセンス認証を行う前に、 次の内容を確認してください。

  • JobAutoを使用するPCでRID(ロボID)を確認していること
  • RIDを製品サポートへ連絡していること
  • 製品サポートからライセンスキーを受け取っていること
  • RIDを確認したWindowsユーザーでWindowsへログインしていること

RIDをまだ確認していない場合は、 先にRID(ロボID)を確認してください。

JobAutoのRID(ロボID)を確認する方法

1.製品サポートから届いたライセンスキーをコピーする

製品サポートから送られてきた ライセンスキーの内容をコピーします。

ライセンスキーの内容を変更せず、 そのままコピーしてください。

2.ロボデザインを起動する

JobAutoを使用するWindowsユーザーで、 ロボデザイン(robo_design.exe)を起動します。

ロボデザインの起動方法

JobAutoがライセンス認証されていない場合は、 ライセンス認証画面が表示されます。

3.ライセンスキーを貼り付ける

ライセンス認証画面の「ライセンスキー」へ、 手順1でコピーした内容を貼り付けます。

貼り付けた内容を確認し、 「認証する」をクリックします。

4.ライセンス認証が完了したことを確認する

ライセンス認証完了の画面が表示されたら、 ライセンス認証は完了です。

ソフトウェアの認証メッセージ。2099年12月31日まで利用可能。

認証完了画面が表示されない場合や、 エラーメッセージが表示された場合は、 下の確認事項をご確認ください。

ライセンス認証できない場合

ライセンス認証できない場合は、 次の項目を確認してください。

RIDを確認したWindowsユーザーと同じか確認する

RIDはWindowsユーザーによって異なります。

RIDを確認したWindowsユーザーと、 ライセンス認証を行っているWindowsユーザーが同じか確認してください。

異なるWindowsユーザーで認証すると、 ライセンス認証に失敗する場合があります。

適用しているライセンスキーを確認する

現在使用しているPCとRIDに対して 製品サポートから発行されたライセンスキーを使用しているか確認してください。

PCを変更した場合は、 旧PCで使用していたライセンスキーではなく、 新しいPCのRIDをもとに発行されたライセンスキーを使用してください。

ライセンスキーを正しくコピーできているか確認する

製品サポートから送られてきたライセンスキーの内容を、 途中で変更せずにそのまま貼り付けてください。

認証完了画面が表示されない場合

上記を確認してもライセンス認証できない場合は、 製品サポートへご連絡ください。

JobAutoを使用するPCを変更した場合

JobAutoを別のPCへ移行した場合は、 新しいPCで確認したRIDをもとに発行された 新しいライセンスキーを使用してください。

旧PCから新PCへJobAutoを移行する場合は、 RIDの確認以外にも、 JobAutoのデータ移行や旧PCのライセンス破棄が必要です。

JobAutoを別のPCへ移行する方法

ロボクライアント(RC)のライセンス認証について

ロボクライアント(RC)のみを使用するPCでは、 ライセンス認証を行う必要はありません。

そのため、 RCのみを使用するPCのRIDを製品サポートへ送る必要もありません。

関連するRID・ライセンス設定

JobAutoでExcelのセルをクリアする方法

★アクションの説明、概要

JobAutoでExcelのセルをクリアする方法について説明します。

「セルのクリア」アクションでは、 操作するブック・シートと対象となるセルを指定し、 セルの値をクリアできます。

クリアタイプでは、 セルの「値のみをクリアする」か、 「書式も含めてすべてクリアする」かを選択できます。

また、処理するデータ量が変わる場合は、 対象となる範囲を行方向や列方向へ拡張して処理することもできます。


★アクションの作成方法


★アクションの設定画面について

アクション設定画面の設定項目についての説明は以下の通りです。

1.基本設定

1-1.ブック

ロボットが開いているExcelのうち、どのExcelを操作対象にするか選択します。名前とインデックスから選択します。

・名前

Excel名で指定します。変数参照可能です。

・インデックス

インデックスで指定します。ロボットがExcelを開いた順番でインデックスが定義されます。

1-2.シート名

セルをクリアするシートを指定します。名前またはインデックスから指定できます。
「エクセルを開く」アクションでCSVファイルを開いた場合は、シートの指定ではデフォルトでインデックスが選択されます。

・名前

シート名で指定します。変数参照可能です。

・インデックス

インデックスで指定します。シートが作成された順番でインデックスが定義されています。

1-3.データ範囲設定

クリアするセル範囲を固定するか、データ量に応じて範囲を拡張するかを設定します。処理する範囲が実行ごとに変わる可能性がある場合は、「範囲を拡張する」を選択します。

・現在の範囲

処理を行う範囲が対象となるセルの範囲に固定されます。

・範囲を拡張する

処理を行う範囲が処理の都度変わる可能性がある場合は、範囲を拡張するを選択します。

・行方向へ拡張する

「範囲を拡張する」を選択した場合に、処理範囲を行方向へ拡張するときはチェックを入れます。

・列方向へ拡張する

「範囲を拡張する」を選択した場合に、処理範囲を列方向へ拡張するときはチェックを入れます。

1-4.対象となるセル

クリアするセルまたはセル範囲を指定します。


2.高度な設定

2-1.クリアタイプ

・書式も含めてすべてクリアする

セルに入っている値だけでなくセルの書式も含めて、すべてクリアします。

・値のみをクリアする

セルに入っている値だけをクリアします。セルの書式はクリアされません。

2-2.アクション有効

このアクションを無効にする場合は、チェックを外します。


3.エラー発生時の対応

3-1. エラー時の処理

エラーが発生したときの設定を行います。詳細はこちらをご確認ください。

3-2.基点となる条件分岐

エラー時の処理で条件分岐の次のフローに移動を選択したときに、設定することができます。アクションでエラーが発生した場合、移動先の条件分岐を選択します。

3-3. エラー時にログ出力

エラーが発生したときにログに出力するか設定します。スケジュール実行したときのログへ出力されます。エラーとして扱わない場合は、チェックを外します。詳細はこちらをご確認ください。


Excelのセルの値だけをクリアする

セルに設定されている値だけを消し、 セルの書式を残したい場合は、 「クリアタイプ」で「値のみをクリアする」を選択します。

「値のみをクリアする」では、 セルに入っている値だけをクリアし、 セルの書式はクリアされません。

セルの書式も含めてすべてクリアする

セルの値だけでなく書式もクリアしたい場合は、 「クリアタイプ」で 「書式も含めてすべてクリアする」を選択します。

この設定では、 セルに入っている値とセルの書式を含めてクリアします。

「値のみ」と「書式も含めてすべて」の違い

クリアタイプセルの値セルの書式
値のみをクリアするクリアする残す
書式も含めてすべてクリアするクリアするクリアする

セルの書式を残してデータだけを消したいのか、 書式も含めてクリアしたいのかに応じて、 クリアタイプを使い分けてください。

「セルのクリア」と「セルの削除」の違い

「セルのクリア」と「セルの削除」は異なるExcel操作です。

アクション用途
セルのクリアセルの位置を残したまま、値または値と書式をクリアします。
セルの削除指定したセルを削除し、残ったセルを左方向または上方向へ移動します。

セルの位置を残したまま内容をクリアしたい場合は「セルのクリア」、 セルそのものを削除して周囲のセルを移動したい場合は 「セルの削除」を使用します。

クリアする範囲を固定する場合

処理するセル範囲が決まっている場合は、 「データ範囲設定」で「現在の範囲」を選択します。

この場合は、 「対象となるセル」で設定した範囲が処理対象になります。

データ量が変わる場合は範囲を拡張する

処理するたびにデータ量が変わる場合は、 「データ範囲設定」で「範囲を拡張する」を選択します。

行方向へ処理範囲を拡張したい場合は 「行方向へ拡張する」、 列方向へ拡張したい場合は 「列方向へ拡張する」を設定します。

セルをクリアしても想定した結果にならない場合

セルのクリアが想定どおりに行われない場合は、 次の順番で設定を確認してください。

  1. 「ブック」で、操作対象となるExcelブックが正しく指定されているか確認します。
  2. 「シート名」で、クリアするシートが正しく指定されているか確認します。
  3. 「対象となるセル」に、 クリアしたいセル範囲が正しく設定されているか確認します。
  4. 処理するデータ量が変わる場合は、 「データ範囲設定」が「現在の範囲」になっていないか確認します。 必要に応じて「範囲を拡張する」を選択します。
  5. 範囲を拡張する場合は、 「行方向へ拡張する」「列方向へ拡張する」の設定を確認します。
  6. セルの値だけをクリアする場合は、 「クリアタイプ」で「値のみをクリアする」が選択されているか確認します。
  7. セルの値だけでなく書式もクリアする場合は、 「書式も含めてすべてクリアする」が選択されているか確認します。

関連するExcel操作・FAQ

JobAutoのロボデザインのログをエクスポートする方法

★ページの説明・概要

JobAutoのロボデザインのログを、 ファイルとしてエクスポートする方法について説明します。

ロボデザインでエラーや想定しない動作が発生した場合などに、 ログをエクスポートして障害調査に利用できます。

JobAutoのサポートへ問い合わせる際に、 ロボデザインの動作状況を確認するため、 エクスポートしたログの送付をお願いする場合があります。

ロボデザインのログとは

ロボデザインのログは、 ロボデザインの動作状況を確認するための情報です。

ロボデザインの操作中にエラーが発生した場合や、 想定した動作にならない場合などに、 原因を調査するための情報として利用します。

通常のロボットファイルやロボット説明書とは異なり、 ロボデザインの動作を調査するために使用するファイルです。

ロボデザインのログをエクスポートする方法

  1. ロボデザインを起動します。
  2. ツールバーの「ロボット」から、 ロボデザインのログを出力するメニューを選択します。
  3. ログのエクスポートを実行します。
  4. 出力されたZIPファイルを確認します。

通常は、 ログのZIPファイルがデスクトップへ自動的に保存されます。

ロボデザインのログをエクスポートする操作については、 以下の操作動画でも確認できます。

ログファイルの保存先

ロボデザインがデスクトップを認識できた場合は、 エクスポートしたログが自動的にデスクトップへ保存されます。

デスクトップを認識できなかった場合は、 ログの出力先フォルダを指定する画面が表示されます。

保存先を選択して、 ログファイルを出力してください。

エクスポートされるファイルについて

ロボデザインのログは、 ZIP形式の圧縮ファイルとしてエクスポートされます。

JobAutoのサポートからログの送付を依頼された場合は、 出力されたZIPファイルを送付してください。

ZIPファイルの中身を変更したり、 必要と思われるファイルだけを抜き出したりせず、 エクスポートされたファイルをそのまま送付すると、 調査に必要な情報を確認しやすくなります。

サポートへ問い合わせる場合

ロボデザインでエラーや想定しない動作が発生し、 JobAutoのサポートへ問い合わせる場合は、 エクスポートしたロボデザインのログを添付してください。

あわせて、 次のような情報を伝えておくと、 発生した事象を確認しやすくなります。

  • どのような操作を行ったときに問題が発生したか
  • 表示されたエラーメッセージ
  • 問題が発生した日時
  • 同じ操作を行うと再度発生するか

「ロボデザインのログ」と「ROBOWEBの実行ログ」の違い

JobAutoには、 ロボデザインのログとは別に、 ROBOWEBで確認するロボットの実行ログがあります。

ログ主な用途
ロボデザインのログロボデザインの動作状況を確認し、 エラーや問題の調査、サポートへの問い合わせなどに利用します。
ROBOWEBの実行ログロボットを実行した結果や、 実行時に発生したエラーなどを確認します。

ロボデザインそのものの動作について調査する場合は、 このページで説明しているログのエクスポートを使用します。

ロボサーバで実行したロボットの実行結果やエラーを確認する場合は、 ROBOWEBのログを確認してください。

ROBOWEBのログについては、 JobAutoのROBOWEBでロボットの実行ログを確認する方法 をご確認ください。

「ロボデザインのログ」と「ロボット説明書」の違い

ロボデザインのログとロボット説明書も、 目的が異なります。

機能主な用途
ロボデザインのログロボデザインの動作やエラーを調査する
ロボット説明書ロボットの構成、アクションの設定内容、 変数などを資料として確認する

作成したロボットの処理内容や設定を確認・共有したい場合は、 ロボット説明書を使用してください。

ロボット説明書については、 JobAutoのロボット説明書を出力する方法 をご確認ください。

関連するロボット操作・ログ

JobAutoで数値を四捨五入・切り上げ・切り捨てする方法

★アクションの説明、概要

JobAutoで変数に格納されている数値を四捨五入・切り上げ・切り捨てする方法について説明します。

「変数の値を加工」アクションの「数値関数」では、処理する桁を指定して、数値を丸めることができます。

四捨五入、切り上げ、切り捨てから目的に合った関数を選択します。

小数点以下だけでなく、10の位や100の位などを指定して数値を丸めることもできます。


★アクションの作成方法


★アクションの設定画面について

アクション設定画面の設定項目について説明します。

数値関数で指定する桁について

関数では処理を行う桁を指定します。

小数第1位を処理して1の位までの値にする場合は「0」を設定します。小数側へ処理する桁を移動する場合は、「1」「2」「3」…と指定します。

整数側の桁を処理する場合は、「-1」「-2」「-3」…と指定します。

1.関数

1-1.四捨五入

指定した桁で数値を四捨五入します。

・四捨五入する桁

四捨五入する桁を指定します。

1-2.切り上げ

指定した桁で数値を切り上げます。

・切り上げする桁

切り上げする桁を指定します。

1-3.切り捨て

指定した桁で数値を切り捨てます。

・切り捨てする桁

切り捨てする桁を指定します。

2.結果

数値関数で処理した結果が表示されます。


数値を四捨五入する場合

数値を指定した桁で四捨五入したい場合は、 「関数」で「四捨五入」を選択します。

「四捨五入する桁」で、 どの桁を処理するか指定します。

数値を切り上げる場合

数値を指定した桁で切り上げたい場合は、 「関数」で「切り上げ」を選択します。

「切り上げする桁」で、 どの桁を処理するか指定します。

数値を切り捨てる場合

数値を指定した桁で切り捨てたい場合は、 「関数」で「切り捨て」を選択します。

「切り捨てする桁」で、 どの桁を処理するか指定します。

数値関数で指定する「桁」の考え方

数値関数では、 処理を行う桁を数値で指定します。

設定値処理する位置の考え方
0小数第1位を処理し、 1の位までの値にします。
1小数第2位を処理し、 小数第1位までの値にします。
2小数第3位を処理し、 小数第2位までの値にします。
-1、-2、-3…整数側の桁を指定して処理します。

たとえば、 250を10の位で切り上げて300にする場合は、 桁に「-2」を設定します。

「四則計算」と「数値関数」の違い

操作用途
四則計算数値に対して、 加算・減算・乗算・除算などの計算を行います。
数値関数数値を四捨五入・切り上げ・切り捨てして、 指定した桁へ丸めます。

「数値関数」と「数値の書式」の違い

操作用途
数値関数数値そのものを 四捨五入・切り上げ・切り捨てします。
数値の書式数値をカンマ区切り、通貨、 パーセントなどの表示形式へ変更します。

数値関数が想定どおりにならない場合の確認順序

  1. 加工対象の変数に、 想定した数値が格納されているか確認します。
  2. 「関数」で、 四捨五入・切り上げ・切り捨ての 目的に合った処理が選択されているか確認します。
  3. 処理する桁の設定が、 目的の位置になっているか確認します。
  4. 小数点以下を処理する場合と、 整数側の桁を処理する場合で、 桁の指定方法を確認します。
  5. 「結果」に表示される値を確認します。
  6. 加工対象の値が文字列の場合は、 必要に応じて「型変換」で 数値型へ変換してから処理します。
  7. 「変数の値を加工」で複数の変換式を設定している場合は、 数値関数の前後に設定されている加工内容も確認します。

関連する変数操作・FAQ

JobAutoでロボットを別のプロジェクトへコピーする方法

★ページの説明・概要

JobAutoのロボデザインで、 作成済みのロボットを別のプロジェクトへコピーする方法について説明します。

現在のプロジェクトで使用しているロボットを、 別のプロジェクトでも利用したい場合に、 ロボットをプロジェクト間でコピーできます。

ロボットをファイルとしてエクスポートしてから 別のプロジェクトへインポートすることなく、 ロボデザイン上でプロジェクト間のコピーを行えます。

ロボットのプロジェクト間コピーとは

プロジェクト間コピーは、 ロボデザインに保存されているロボットを、 現在のプロジェクトとは別のプロジェクトへコピーする機能です。

たとえば、 共通する処理を行うロボットを 別のプロジェクトでも利用したい場合などに使用できます。

この機能は、 バージョン0.10.4から利用できます。

ロボットを別のプロジェクトへコピーする方法

  1. コピーするロボットが保存されているプロジェクトを ロボデザインで開きます。
  2. 別のプロジェクトへコピーするロボットを選択します。
  3. ツールバーの「ロボット」から、 ロボットをプロジェクト間でコピーする機能を選択します。
  4. コピー先となるプロジェクトを選択します。
  5. コピーするロボットとコピー先プロジェクトを確認し、 コピーを実行します。
  6. コピー先のプロジェクトを開き、 ロボットがコピーされていることを確認します。

ロボットを別のプロジェクトへコピーする操作については、 以下の操作動画でも確認できます。

プロジェクト間コピーを利用するケース

たとえば、次のような場合に ロボットのプロジェクト間コピーを利用できます。

  • 別のプロジェクトでも似た処理を行うロボットを作成したい
  • 既存のロボットを元に、 別プロジェクト用のロボットを作成したい
  • ロボットをファイルへエクスポートせず、 ロボデザイン上で別のプロジェクトへコピーしたい

「ロボットをコピーする」と「プロジェクト間コピー」の違い

JobAutoには、 同じプロジェクト内でロボットをコピーする機能と、 別のプロジェクトへコピーする機能があります。

操作コピー先用途
ロボットをコピーする現在のプロジェクト既存のロボットを元に、 同じプロジェクト内で新しいロボットを作成します。
プロジェクト間コピー別のプロジェクト作成済みのロボットを、 別のプロジェクトへコピーします。

現在のプロジェクト内でロボットを複製する場合は、 通常の「ロボットをコピーする」を使用してください。

詳しい操作方法については、 JobAutoでロボットをコピーする方法 をご確認ください。

「プロジェクト間コピー」と「エクスポート・インポート」の違い

別のプロジェクトへロボットを移す方法として、 エクスポートとインポートを使用する方法もありますが、 用途が異なります。

方法主な用途
プロジェクト間コピー現在のロボデザイン内にあるロボットを、 別のプロジェクトへコピーします。
エクスポート・インポートロボットをファイルとして保存し、 別の環境や別のPCなどへ受け渡します。

同じロボデザイン内の別プロジェクトへコピーするだけであれば、 プロジェクト間コピーを利用できます。

別のPCへロボットを渡す場合などは、 ロボットをエクスポートし、 移行先のロボデザインへインポートします。

エクスポートについては、 JobAutoでロボットをエクスポートする方法 をご確認ください。

インポートについては、 JobAutoでロボットをインポートする方法 をご確認ください。

プロジェクト間コピーを行うときの注意

コピー先のプロジェクトを確認する

コピーを実行する前に、 コピー先として選択したプロジェクトに間違いがないことを 確認してください。

複数のプロジェクトを使用している場合は、 似た名前のプロジェクトへ誤ってコピーしないよう注意してください。

コピー後にロボットの内容を確認する

コピーが完了したら、 コピー先のプロジェクトを開き、 対象のロボットがコピーされていることを確認してください。

コピーしたロボットを別プロジェクトの処理として使用する場合は、 実際の運用に合わせてロボットの設定内容も確認してください。

共通部品を別のプロジェクトへコピーする場合

JobAutoでは、 ロボットだけでなく共通部品についても、 別のプロジェクトへコピーする機能があります。

ロボットで使用する共通部品を 別のプロジェクトでも利用する場合は、 共通部品のプロジェクト間コピーについても確認してください。

詳しい操作方法については、 JobAutoで共通部品をプロジェクト間コピーする方法 をご確認ください。

関連するロボット操作

JobAutoで数値の書式を変更する方法|カンマ・通貨・パーセント

★アクションの説明、概要

JobAutoで変数に格納されている数値の書式を変更する方法について説明します。

「変数の値を加工」アクションの「数値の書式」では、数値をカンマ区切り、通貨、パーセントなどの書式へ変更できます。

「書式」から、目的に合った表示形式を選択します。

数値を計算するのではなく、後続処理で使用する数値の表記を目的に合わせて変更したい場合に使用します。


★アクションの作成方法


★アクションの設定画面について

アクション設定画面の設定項目について説明します。

1.書式

数値に設定する書式をプルダウンから選択します。

1-1.カンマ区切り

数値をカンマ区切りの書式へ変更します。

1-2.通貨

数値を通貨の書式へ変更します。

1-3.パーセント

数値をパーセントの書式へ変更します。

2.結果

書式を変更した結果が表示されます。


数値をカンマ区切りにする場合

数値をカンマ区切りの書式へ変更したい場合は、 「書式」で「カンマ区切り」を選択します。

桁数の多い数値を、 カンマ付きの表記にしたい場合などに使用できます。

数値を通貨表記にする場合

数値を通貨の書式へ変更したい場合は、 「書式」で「通貨」を選択します。

金額として使用する数値を 通貨表記にしたい場合などに使用できます。

数値をパーセント表記にする場合

数値をパーセントの書式へ変更したい場合は、 「書式」で「パーセント」を選択します。

割合などの数値を パーセント表記にしたい場合に使用できます。

目的に応じた数値操作の選び方

やりたいこと使用する操作
数値を加算・減算・乗算・除算したい四則計算
数値を四捨五入・切り上げ・切り捨てしたい数値関数
数値をカンマ区切り、通貨、パーセント表記にしたい数値の書式

「数値の書式」と「四則計算」の違い

操作用途
数値の書式数値の表記を、 カンマ区切り、通貨、パーセントなどの 書式へ変更します。
四則計算数値に対して 加算・減算・乗算・除算などの計算を行います。

「数値の書式」と「数値関数」の違い

操作用途
数値の書式数値の表示形式を変更します。
数値関数数値を四捨五入・切り上げ・切り捨てして、 指定した桁へ丸めます。

数値の書式が想定どおりにならない場合の確認順序

  1. 加工対象の変数に、 想定した値が格納されているか確認します。
  2. 「書式」で、 目的に合った書式が選択されているか確認します。
  3. カンマ区切り、通貨、パーセントの どの書式を使用するか確認します。
  4. 「結果」に表示される内容を確認します。
  5. 加工対象の値が文字列として扱われている場合は、 必要に応じて「型変換」で数値型への変換を確認します。
  6. 「変数の値を加工」で複数の変換式を設定している場合は、 数値の書式の前後に設定されている加工内容も確認します。

関連する変数操作・FAQ

JobAutoで共通部品を別のプロジェクトへコピーする方法

★ページの説明・概要

JobAutoのロボデザインで、 作成済みの共通部品を別のプロジェクトへコピーする方法について説明します。

現在のプロジェクトで使用している共通部品を、 別のプロジェクトでも利用したい場合に、 共通部品をプロジェクト間でコピーできます。

共通部品をファイルとしてエクスポートしてから 別のプロジェクトへインポートすることなく、 ロボデザイン上で別のプロジェクトへコピーできます。

共通部品のプロジェクト間コピーとは

プロジェクト間コピーは、 ロボデザインに保存されている共通部品を、 現在のプロジェクトとは別のプロジェクトへコピーする機能です。

複数のプロジェクトで同じような共通処理を使用したい場合や、 既存の共通部品を元に別プロジェクト用の共通部品を作成したい場合などに利用できます。

この機能は、 バージョン0.10.4から利用できます。

共通部品を別のプロジェクトへコピーする方法

  1. コピーする共通部品が保存されているプロジェクトを ロボデザインで開きます。
  2. コピーする共通部品を確認します。
  3. ツールバーの「共通部品」から、 共通部品をプロジェクト間でコピーする機能を選択します。
  4. コピー先となるプロジェクトを選択します。
  5. コピーする共通部品とコピー先プロジェクトを確認し、 コピーを実行します。
  6. コピー先のプロジェクトを開き、 共通部品がコピーされていることを確認します。

操作動画

共通部品を別のプロジェクトへコピーする操作については、 現在のページに掲載されている操作動画でも確認できます。

プロジェクト間コピーを利用するケース

たとえば、次のような場合に 共通部品のプロジェクト間コピーを利用できます。

  • 別のプロジェクトでも同じ共通処理を利用したい
  • 既存の共通部品を元に、 別プロジェクト用の共通部品を作成したい
  • 共通部品をファイルへエクスポートせず、 ロボデザイン上で別のプロジェクトへコピーしたい

「共通部品をコピーする」と「プロジェクト間コピー」の違い

JobAutoには、 同じプロジェクト内で共通部品をコピーする機能と、 別のプロジェクトへコピーする機能があります。

操作コピー先用途
共通部品をコピーする現在のプロジェクト既存の共通部品を元に、 同じプロジェクト内で別の共通部品を作成します。
プロジェクト間コピー別のプロジェクト作成済みの共通部品を 別のプロジェクトへコピーします。

現在のプロジェクト内で 共通部品を複製したい場合は、 通常の「共通部品をコピーする」を使用してください。

詳しい操作方法については、 JobAutoで共通部品をコピーする方法 をご確認ください。

「プロジェクト間コピー」と「エクスポート・インポート」の違い

別のプロジェクトで共通部品を使用する方法として、 エクスポートとインポートを使用する方法もありますが、 用途が異なります。

方法主な用途
プロジェクト間コピー現在のロボデザイン内に保存されている共通部品を、 別のプロジェクトへコピーします。
エクスポート・インポート共通部品をファイルとして保存し、 別のPCや別の環境などへ受け渡します。

同じロボデザイン内の別プロジェクトで 共通部品を利用したい場合は、 プロジェクト間コピーを利用できます。

別のPCや別の環境へ共通部品を渡す場合は、 共通部品をエクスポートし、 移行先のロボデザインへインポートします。

共通部品をエクスポートする方法については、 JobAutoで共通部品をエクスポートする方法 をご確認ください。

共通部品をインポートする方法については、 JobAutoで共通部品をインポートする方法 をご確認ください。

共通部品をコピーするときの注意

コピー先のプロジェクトを確認する

コピーを実行する前に、 コピー先として選択したプロジェクトに 間違いがないことを確認してください。

複数のプロジェクトを使用している場合は、 似た名前のプロジェクトへ誤ってコピーしないよう注意してください。

コピー後に共通部品を確認する

コピーが完了したら、 コピー先のプロジェクトを開き、 対象の共通部品がコピーされていることを確認してください。

コピーした共通部品を編集する場合は、 先にロボットを開いてから共通部品を開いてください。

一部のアクションは、 ロボットが開かれていることを前提として動作します。

共通部品を開く方法については、 JobAutoで共通部品を開く方法 をご確認ください。

ロボットを別のプロジェクトへコピーする場合

JobAutoでは、 共通部品だけでなくロボットについても、 別のプロジェクトへコピーできます。

ロボットを別のプロジェクトへコピーする方法については、 JobAutoでロボットを別のプロジェクトへコピーする方法 をご確認ください。

「カスタムアクション」と「共通部品」について

バージョン0.10.4から、 従来の「カスタムアクション」は 「共通部品」という名称に変更されました。

名称が変更されていますが、 機能そのものに変更はありません。

古いJobAutoのマニュアルや資料で 「カスタムアクション」と記載されている場合は、 現在の「共通部品」を指しています。

関連する共通部品操作

JobAutoで指定した文字が出るまで待つ方法

★アクションの説明、概要

JobAutoで指定した文字がアプリ画面に表示されるまで、 ロボットの処理を待機させる方法について説明します。

「指定の文字が出るまで待つ」アクションでは、 アプリ画面をOCRで解析し、 指定した文字が画面内に表示されるまで処理を一時停止します。

画面の読み込みや処理の完了などによって 特定の文字が表示されるのを待ってから、 次のアクションへ進みたい場合に使用します。

文字認識にはGoogleのAPIを使用します。 OCR変換する文字はJobAutoからGoogleへ送信されるため、 インターネットへの接続が必要です。

インターネット接続にプロキシサーバを使用している環境では、 プロキシの設定を行ってください。 また、インターネットへのアクセス先を制限している場合は、 vision.googleapis.comへの通信を許可してください。


★アクションの作成方法


★アクションの設定画面について

アクション設定画面の設定項目について説明します。「画面を読み込み」「操作対象にフォーカス」「背景色」については、アプリデザインの使い方をご確認ください。

1.基本設定

1-1.文字が見つかるまでのタイムアウト(秒)

設定した時間まで、指定した文字をロボットが探し続けます。

1-2.対象となる値

画面内から探す文字を設定します。対象となる値には変数を使用できます。

・検索ボタン 

対象となる値に設定された文字を画面内から探します。

1-3.プロキシ

Googleへの通信を行うときに、プロキシサーバを経由するかどうかを設定します。

・Proxyを使用する

プロキシサーバを経由してGoogleへ通信します。

・Proxyを使用しない

プロキシサーバを経由せずGoogleへ通信します。

1-4.変換時のオプション

OCRで変換するときに優先する言語を設定します。

・日本語を優先しない

日本語を優先せずにOCR変換します。

・日本語を優先する

日本語を優先してOCR変換します。


2.高度な設定

2-1.アクション有効

このアクションを無効にする場合は、チェックを外します。

2-2.一致したイメージショットをログに残す

チェックを入れた状態でスケジュール実行すると、実行ログに処理対象として認識した文字が画像として表示されます。


3.エラー発生時の対応

3-1.エラー時の処理

エラーが発生したときの設定を行います。詳細はこちらをご確認ください。

3-2.基点となる条件分岐

エラー時の処理で条件分岐の次のフローに移動を選択したときに、設定することができます。アクションでエラーが発生した場合、移動先の条件分岐を選択します。

3-3.エラー時にログ出力

エラーが発生したときにログに出力するか設定します。スケジュール実行したときのログへ出力されます。エラーとして扱わない場合は、チェックを外します。詳細はこちらをご確認ください。


「指定の文字が出るまで待つ」とは

「指定の文字が出るまで待つ」では、 アプリ画面をOCRで解析し、 あらかじめ指定した文字が表示されるまで ロボットの処理を一時停止します。

指定した文字が表示されたことを確認してから 次のアクションへ進みたい場合に使用します。

決まった時間待つ場合との違い

「指定の文字が出るまで待つ」は、 単純に一定時間だけ処理を停止するアクションではありません。

設定したタイムアウト時間まで、 指定した文字をOCRで探しながら待機します。

画面の表示にかかる時間が毎回異なる場合など、 特定の文字が表示されたことを 次の処理へ進む条件として使用できます。

待機条件となる文字を指定する

「対象となる値」には、 アプリ画面内から探す文字を設定します。

対象となる値は変数参照できます。 前の処理で取得した値などを変数へ格納し、 その文字が表示されるまで待機することもできます。

指定した文字をOCRで認識できるか確認する

「対象となる値」の検索ボタンを使用すると、 設定した文字を現在のアプリ画面から探すことができます。

画面上に目的の文字が表示されている場合は、 アクションを作成するときに検索ボタンを使い、 JobAutoがその文字を認識できるか確認してください。

日本語を優先して文字を認識する

「変換時のオプション」では、 OCR変換するときに日本語を優先するか設定できます。

設定動作
日本語を優先しない日本語を優先せずにOCR変換します。
日本語を優先する日本語を優先してOCR変換します。

日本語の文字を待機条件としている場合は、 実際の認識結果を確認しながら設定してください。

文字認識ではGoogleとの通信が発生します

「指定の文字が出るまで待つ」では、 OCR変換にGoogleのAPIを使用します。

OCR変換する文字はJobAutoからGoogleへ送信されるため、 このアクションを実行するには インターネットへの接続が必要です。

インターネットへのアクセス先を制限している環境では、 vision.googleapis.comへの通信を許可してください。

プロキシ環境で使用する場合

インターネット接続にプロキシサーバを使用している環境では、 「プロキシ」の設定を確認してください。

設定動作
Proxyを使用するプロキシサーバを経由してGoogleへ通信します。
Proxyを使用しないプロキシサーバを経由せずGoogleへ通信します。

スケジュール実行時に認識した文字を確認する

高度な設定の 「一致したイメージショットをログに残す」を有効にすると、 スケジュール実行時のログに 処理対象として認識した文字がイメージとして表示されます。

想定した文字とは異なる箇所を認識して 次の処理へ進んでいる場合などは、 ログに残されたイメージも確認してください。

「画像が出るまで待つ」との違い

「指定の文字が出るまで待つ」と 「画像が出るまで待つ」は、 どちらも特定の表示を待ってから 次の処理へ進むためのアクションですが、 待機条件の認識方法が異なります。

アクション待機条件の認識方法
指定の文字が出るまで待つ画面上の文字をOCRで認識して待機します。
画像が出るまで待つ画面上の画像を使って待機します。

待機条件として使用できる文字が画面に表示されている場合は、 文字マッチングを利用できるか確認してください。

指定した文字が見つからない場合

画面上に目的の文字が表示されているのに 待機が終了しない場合は、 次の点を確認してください。

  1. 操作対象となるアプリへ正しく接続しているか
  2. アプリデザインに最新の画面が表示されているか
  3. 「対象となる値」が実際に画面へ表示されている文字と合っているか
  4. 検索ボタンで目的の文字を認識できるか
  5. 日本語を含む場合は「日本語を優先する」の設定が適切か
  6. インターネットへ接続できるか
  7. プロキシ環境ではプロキシ設定が適切か
  8. vision.googleapis.comへの通信が制限されていないか
  9. 文字の表示に時間がかかる場合はタイムアウト時間が適切か

関連するアプリ操作・FAQ